New Zealand Supplier having internet issues
Incident Report for JobBag Status
Resolved
Issues have now been resolved by the supplier
Posted Oct 21, 2022 - 13:05 AEDT
Investigating
We are currently investigating with our suppliers what the issue is and a time frame for the fix
Posted Oct 21, 2022 - 12:26 AEDT
This incident affected: New Zealand.